×

通达信万能指标公式

wwwlinqiu wwwlinqiu 发表于2022-05-04 21:22:48 浏览122 评论0

抢沙发发表评论

1.jpg

N:=5;

P:=0.24;

{有庄控盘}

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;

A10:=CROSS(控盘,0);

无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;

开始控盘:IF(A10,1,0),LINETHICK1,COLORBROWN;

STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;

有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;

VAR2:=100*WINNER(CLOSE*0.95);

STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;

高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;

STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;

主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;

DRAWICON(开始控盘,-2,15);

{底部显现}

AVAR2:=REF(LOW,1);

AVAR3:=SMA(ABS(LOW-AVAR2),13,1)/SMA(MAX(LOW-AVAR2,0),13,1)*100;

AVAR4:=EMA(IF(CLOSE*1.2,AVAR3*13,AVAR3/13),13);

AVAR5:=LLV(LOW,34);

AVAR6:=HHV(AVAR4,34);

AVAR7:=IF(LLV(LOW,56),1,0);

AVAR8:=EMA(IF(LOW<=AVAR5,(AVAR4+AVAR6*2)/2,0),3)/618*AVAR7;

AA:=AVAR8>REF(AVAR8,1);

DJ:=REF(LLV(L,100),3);

ZD:=REFDATE(DJ,DATE);

XG:=L=ZD;

XGA:=AA AND XG;

XG1:=XGA>REF(XGA,1);

底部:XG1>REF(XG1,1);

DRAWTEXT(底部,-6,'底部'),COLORYELLOW;

STICKLINE(底部,-4,-1,1,0),COLORCYAN,LINETHICK4;

DRAWICON(底部,-3,26);

{仙人指}

V1:=CLOSE/REF(CLOSE,3)>=1.1;

V2:=BACKSET(V1,2);

仙人指:V2 AND COUNT(V2,2)=1;

STICKLINE( 仙人指,-6,-3,1,0),COLORYELLOW,LINETHICK4;

DRAWICON(仙人指,-4,11);

DRAWTEXT(仙人指,-7,'仙人指'),COLORYELLOW;

AAD:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);

GD:=DMA(CLOSE,AAD);

SS:=(1+9/100)*GD;

XX:=(1-9/100)*GD;

ZTD:=C/REF(C,1)>1.092 AND C/REF(C,1)<1.1035 AND C=H;

A1:=REF(COUNT(ZTD,6)=1,1);

A2:=REF(SUM((C-REF(C,1))/C*100,2)<-5,1) OR REF(SUM((C-REF(C,1))/C*100,5)<-10,1);

VD1:=AMOUNT/VOL/7;

VD2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

VD3:=SUM(AMOUNT,10)/VD1/7;

VD4:=DMA(VD2,VOL/VD3);

VD5:=(CLOSE-VD4)/VD4*100;

VD6:=CROSS(VD5,-5) OR CROSS(VD5,-10);

VD7:=C/REF(C,20)<1.3 OR REF(C,3)/REF(C,20)<1.3;

A3:=A1 AND A2 AND C>XX AND C<GD AND C/REF(C,1)>1.01 AND VD6 AND VD7;

板后回调:IF(A3,1,0),LINETHICK1,COLORYELLOW;

DRAWTEXT(板后回调,-7,'板后回调'),COLORYELLOW;

STICKLINE(板后回调,-2,-18,3,0),COLORYELLOW,LINETHICK2;

{游资接力}

HJXX_1:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);

HJXX_2:=EMA(HIGH,30)*1.15;

HJXX_3:=EMA(HIGH,3)*1.03;

游资接力:CROSS(CLOSE,HJXX_3) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1) > 0.04 ;

STICKLINE(游资接力,-1.5,-20,1.5,0),COLORFFFF00;

DRAWTEXT(游资接力,-20,' 游资接力'),COLORRED;

{神秘底}

MA55:=MA(C,55);

EXPA:=EXPMA(C,6)COLORRED,LINETHICK2;

M5:=MA(CLOSE,5)COLORWHITE;

M5138线:=MA(C,5)-MA(C,13)+MA(C,8),COLORCYAN,LINETHICK1;

M52:=MA(M5138线,2),COLORYELLOW,LINETHICK1;

M53:=(M5138线*1.045),COLORYELLOW,LINETHICK1;

M54:=(M5138线*1.090),COLORYELLOW,LINETHICK1;

M55:=(M5138线*1.135),COLORYELLOW,LINETHICK1;

DIF0:=CROSS(C,M5138线),COLORYELLOW,LINETHICK1;

DI:=CROSS(M5138线,M52);

先行:=LLV(MA(HIGH,(3)),1),LINETHICK2,COLORRED;

先行2:=LLV(MA(HIGH,(3)),2),LINETHICK2,COLORWHITE;

M38线:=MA(C,5)-MA(C,13)+MA(C,8),COLORCYAN,LINETHICK1;

M522:=MA(M38线,2),COLORYELLOW,LINETHICK1;

M3852:=CROSS(M38线,M522);

C先行:=CROSS(C,先行);

DDTD:=DMA(C,ABS(C-MA(C,14))/MA(C,14));

上布:=EMA(DDTD,30)*1.2,COLORGREEN;

上布2:=MA(上布,3)COLORWHITE;

上布涨:=IF(上布>REF(上布,1),1,0),COLORWHITE;

中上轨:=EMA(2.055*EMA(EMA(H,34),34)-EMA(EMA(L,34),34),5),COLORCYAN,LINETHICK2;

下布:=EMA(DDTD,30)*0.91,COLORMAGENTA;

中下轨:=EMA(2*EMA(EMA(L,21),21)-EMA(EMA(H,21),21),5),COLORYELLOW,LINETHICK2;

C轨:=IF(C>中下轨,0,1)COLORWHITE;

角度上布:=ATAN((上布/REF(上布,1)-1)*100)*180/3.141592654,NODRAW,COLORWHITE;

角度MA5:=ATAN((M5/REF(M5,1)-1)*100)*180/3.141592654,NODRAW,COLORWHITE;

中下轨2:=IF(中下轨>REF(中下轨,1),1,0),COLORWHITE;

下下轨:=EMA((3*C+H+O+L)/6,30)*0.89,COLORMAGENTA,NODRAW;

{神秘底}

TJ5:=REF("CCI.CCI",1)<-100 AND "CCI.CCI">REF("CCI.CCI",1);

TJ6:=REF("KDJ.J"(9,3,3),1)<20 AND "KDJ.J"(9,3,3)>REF( "KDJ.J"(9,3,3),1);

TJ7:=REF("RSI.RSI1",1)<20 AND "RSI.RSI1">REF("RSI.RSI1",1);

TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);

TJ9:=3075.2525*400;

建仓:=1;

大底:=CROSS(TJ8,0.5);

{DRAWICON(大底,L*0.95,23);}

神秘1:=CROSS(大底,0.001),COLOR0FB9FF;

神密底:IF(下布>M38线 AND 中下轨>下布 AND 建仓 AND 大底,30.2,0),STICK,COLORCYAN,LINETHICK6;

DRAWTEXT(CROSS(神密底,1),神密底-神密底*0.15,'↖底现'),COLORCYAN;

上线:=SMA(C,6.5,1);

下线:=SMA(C,13.5,1);

买入:=CROSS(上线,下线),COLORMAGENTA;

潜伏区:IF(买入>0.001 AND 建仓,30.2,0),STICK,COLORLIMAGENTA,LINETHICK6;

DRAWTEXT(CROSS(潜伏区,1),潜伏区-潜伏区*0.15,' ↖潜入'),COLORLIMAGENTA;

Y:35,COLORBLACK;

群贤毕至

访客