×

通达信资金趋势主图指标公式

wwwlinqiu wwwlinqiu 发表于2022-03-19 14:01:00 浏览192 评论0

抢沙发发表评论

1.jpg

SHORT:=12;LONG:=26;M:=12;

DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

DEA:=EMA(DIF,M);

macd:=2*(DIF-DEA);

KK:=IF(DIF>DEA,5,-5);

JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}

DD:=(MacD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}

DIF拐头价:=(DIF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORGREEN,POINTDOT;

金死叉价:=(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),NODRAW;

柱变向价:=(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),COLORYELLOW,POINTDOT;

黄铢消失见顶:=IF(柱变向价>=DIF拐头价,柱变向价,DRAWNULL),COLORYELLOW,CIRCLEDOT,LINETHICK1;

上拐:IF(DIF拐头价<柱变向价,DIF拐头价,DRAWNULL),COLORRED,LINETHICK4;

下拐:IF(DIF拐头价>=柱变向价,DIF拐头价,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;

ZJ:=上拐,COLOR0000FF;

HY:=金死叉价,COLORFF00FF;

IF(ZJ>REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;

IF(HY>REF(HY,1),HY,DRAWNULL),COLORMAGENTA,LINETHICK2,NODRAW;

IF(HY<REF(HY,1),HY,DRAWNULL),COLORBLUE,LINETHICK2,NODRAW;

stICKLINE(C>ZJ AND C>O,H,C,0,0 ),COLORRED;

STICKLINE(C>ZJ AND C>O,L,O,0,0 ),COLORRED;

STICKLINE(C>ZJ AND C>O,O,C,2.8,1),COLORRED;

STICKLINE(C>ZJ AND C<=O,H,L,0,0 ),COLORRED;

STICKLINE(C>ZJ AND C<=O,O,C,2.8,0),COLORRED;

STICKLINE(CLOSE=ZJ,H,L,3,0),COLORWHITE;

STICKLINE(CLOSE<ZJ,H,L,0,0),COLORYELLOW;

STICKLINE(CLOSE<ZJ,O,C,2.5,0),COLORYELLOW;

STICKLINE(C<HY AND C>O,H,C,0,0),COLORCYAN;

STICKLINE(C<HY AND C>O,O,L,0,0),COLORCYAN;

STICKLINE(C<HY AND C>O,O,C,2.8,1),COLORCYAN;

STICKLINE(C<HY AND C<=O,H,L,0,0),COLORCYAN;

STICKLINE(C<HY AND C<=O,O,C,2.8,0),COLORCYAN;

HD0:=crOSS(DIF,DEA);

金收:REF(L,BArslAST(HD0)),COLORYELLOW,DOTLINE;

LD0:=CROSS(DEA,DIF);

死收:REF(H,BARSLAST(LD0)),COLOR00FF00,DOTLINE;

买入准备:DRAWICON(CROSS(柱变向价,DIF拐头价),上拐,34);

卖出准备:DRAWICON(CROSS(DIF拐头价,柱变向价),下拐,35);

SBL:=STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,HYBLOCK),FGBLOCK),GNBLOCK),ZDBLOCK);

DRAWTEXT_FIX(ISLASTBAR,0.01,0.005,0,SBL),COLORCYAN;


群贤毕至

访客