×

通达信操盘擒庄指标公式

wwwlinqiu wwwlinqiu 发表于2022-03-04 18:55:07 浏览204 评论0

抢沙发发表评论

2.jpg

DRAWGBK(CURRBARSCOUNT=1 , RGB(0,0,0),RGB(0,0,0),0,'1',0);

BIAS6 :(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*200,NODRAW ;

STICKLINE(BIAS6>=REF(BIAS6,1),0,ABS(BIAS6),3.0,0),COLORYELLOW ;

A62:=((CLOSE - (LLV(LOW,36))) / ((HHV(HIGH,36)) - (LLV(LOW,36)))) * 100;

A63:=SMA(A62,3,1);

A64:=SMA(A63,3,1);

A65:=SMA(A64,3,1);

A66:=(CROSS(A64,A65)) AND (A64 < 12);

STICKLINE(((FILTER(A66,10)) = 1),0,80,2,1),COLORMAGENTA ;

AIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

AEA:=EMA(AIFF,9),COLORWHITE;

AACD:=(AIFF-AEA)*2;

A:STICKLINE(AACD>=0 AND AACD>=REF(AACD,1) AND REF(AACD,1)<0

AND AACD>=0.01,90,AACD,1,1) ,COLORRED;

DRAWTEXT(A,85,' 一飞冲天'),COLORYELLOW ;

{RV1:=(C-MA(C,4))/MA(C,4)*100;

CDMA:EMA(EMA(RV1,7),7)*4,NODRAW,COLORWHITE;

STICKLINE(CDMA>=0 AND CDMA>=REF(CDMA,1),50,50+CDMA,1.0,0),COLORRED ;}

启动线:=10*SUM(EMA((C+L)/2,2),5)/10.158,NODRAW;

平衡线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,4),NODRAW;

平台线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,10),NODRAW;

强弱线:=EMA(启动线,21);

VVAR1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;

VVAR2:=IF((EMA((C+L)/2,3)-VVAR1)*5>0,POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10,-1*POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10);

VVAR3:=IF(VVAR2>0,VVAR2-0,0);

STICKLINE(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),0,25,0,0),COLORMAGENTA;

DRAWTEXT(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),30,'动'),COLORMAGENTA;

顶:90,COLORYELLOW,LINETHICK1;

强:80,COLORRED,LINETHICK2;

黄柱过线成妖:25,COLORMAGENTA ,LINETHICK1;

弱:10,COLORGREEN,LINETHICK3;

DRAWTEXT(ISLASTBAR, 顶,' 顶'),COLORYELLOW;

DRAWTEXT(ISLASTBAR, 强,' 强'),COLORRED;

DRAWTEXT(ISLASTBAR, 黄柱过线成妖,'黄柱过线成妖 '),COLORYELLOW ;

DRAWTEXT(ISLASTBAR, 弱,' 弱'),COLORGREEN;

VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

K1:SMA(VAR13,3,1),COLORCYAN,LINETHICK1;

VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

K2:SMA(VAR21,3,1),COLORYELLOW,LINETHICK1;

VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

K3:SMA(VAR34,3,1),COLORMAGENTA,LINETHICK1;

VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;

K4:SMA(VAR55,3,1),COLOR00FF00,NODRAW;

买点:K1<20 AND K1>REF(K1,1) AND K2<20

AND K3<20 ,COLORRED,NODRAW;

STICKLINE(买点 ,105,100,2,0),COLORGREEN ;

TOBU:= K3>80 AND K2>80 ;

STICKLINE(TOBU=1,105,100,1,0) ,COLORRED;

DD:=-10;

DRAWTEXT(ISLASTBAR,K1,' '),COLORCYAN ;

DRAWTEXT(ISLASTBAR,K2,' ←拉升线'),COLORYELLOW ;

DRAWTEXT(ISLASTBAR,K3,' ←主力线'),COLORMAGENTA ;

{买了不输}

A1:=AMOUNT/VOL/1000;

B2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

D3D:=SUM(AMOUNT,13)/A1/1000;

E4:=DMA(B2,VOL/D3D);

买了不输:=(CLOSE-E4)/E4*1000;

VARX:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

VARX1:=SMA(VARX,3,1);

VARX2:=SMA(VARX1,3,1);

VARX3:=REF(LOW,1);

VARX4:=SMA(ABS(LOW-VARX3),3,1)/SMA(MAX(LOW-VARX3,0),3,1)*100;

VARX5:=EMA(IF(CLOSE*1.2,VARX4*10,VARX4/10),3);

VARX6:=LLV(LOW,30);

VARX7:=HHV(VARX5,30);

VARX8:=IF(LLV(LOW,58),1,0);

VARX9:=(EMA(IF(LOW<=VARX6,(VARX5+VARX7*2)/2,0),3)/618*VARX8);

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK2;

DEA:=EMA(DIFF,9),LINETHICK2;

MACD:=(DIFF-DEA)*2;

DIF55:=(EMA(CLOSE,30)-EMA(CLOSE,100));

DEA55:=(EMA(DIF55,45));

F60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2),COLORFF00FF;

A60:=EMA(F60,9/2),COLORGREEN;

F30:=(EMA(CLOSE,12/4)-EMA(CLOSE,26/4)),COLORBLUE,LINETHICK1;

A30:=(EMA(F30,9/4)),COLORWHITE;

{买了就涨}

买1:=MA(CLOSE,1);

卖1:=(LOW+HIGH+CLOSE)/3;

VARR1:=MA(卖1,5);

VARR2:=HHV(VARR1,10);

DM:=IF(HHV((买1<VARR2),5),100,85),COLORFFFF00,LINETHICK1;

MAI:=IF(HHV((买1<VARR2),10),105,100),COLORGREEN,LINETHICK1;

{DRAWBAND(100,RGB(0,250,250),DM,RGB(0,0,0));

DRAWBAND(100,RGB(240,240,0),MAI,RGB(0,0,0));}

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);

VARR3:=(((DMP ) * 100) / TR);

VARR4:=((DMM * 100) / TR);

XXX:=(MA(((ABS((VARR4 - VARR3)) / (VARR4 + VARR3)) * 100),3));

买卖:=LLV(VARR1,10);

DMAI:=IF(LLV((买1<买卖),5),15,0),COLORRED,LINETHICK2;

MAI2:=IF(LLV((买1<买卖),10),20,0),COLORFF00FF,LINETHICK3;

短买:IF(DMAI AND VAR55<20,10,0),COLORYELLOW,LINETHICK2,NODRAW;

STICKLINE(短买 ,105,100,2,0),COLORYELLOW ;

买:=MAI2,COLORYELLOW,LINETHICK2;

{寻宝}

RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

VR44:=SMA(RV,3,1);

VR55:=SMA(VR44,3,1);

KK:=EMA(SMA(RG,3,1),2);EE:=SMA(KK,3,1);

X:=CROSS(VR44,VR55) AND VR55<30;

X1:=CROSS(VR44,VR55) AND CROSS(KK,EE);

XG1:=X OR X1;

寻宝:=C-REF(C,1);

股海:=100*EMA(EMA(寻宝,6),6)/EMA(EMA(ABS(寻宝),6),6);

捡金:=LLV(股海,2)=LLV(股海,7) AND COUNT(股海<0,2) AND CROSS(股海,MA(股海,2));

笨哥:=(C-REF(C,20))/REF(C,20)*100<0;

XG2:=(FILTER(捡金=1,5))AND("CCI">0);

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

XG3:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

K11:=SMA(RSV1,5,1);

D11:=SMA(K11,5,1);

J11:=3*K11-2*D11;

AA1:=EMA(J11,5);

AA2:=REF(AA1,1);

RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K22:=SMA(RSV2,3,1);

D22:=SMA(K22,3,1);

J22:=3*K22-2*D22;

BB1:=EMA(J22,5);

BB2:=REF(BB1,1);

D1D:=AA1>AA2 AND BB1>BB2;

XG4:=(D1D AND NOT(REF(D1D,1)) AND (AA1<50 OR BB1<50));

N:=5;{可调}

BB:=REF(CLOSE,N);

CC:=SMA(MAX(CLOSE-BB,0),2,1)/SMA(ABS(CLOSE-BB),2,1)*100-50;

线:=CC;

XG5:=线>REF(线,1) AND REF(线,1)<=REF(线,2) AND C/REF(C,1)>1;

宝:IF(XG1+XG2+XG3+XG4+XG5>=4,50,0),COLORWHITE,NODRAW;

STICKLINE(XG1+XG2+XG3+XG4+XG5>=4,0,20,1,1),COLORYELLOW ;

空方:100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55)),COLORBLUE, ;

DRAWTEXT(ISLASTBAR,空方,' ←空方'),COLORGREEN;

{AA:=(O+H+L+C)/4;

C1:=HHV(AA,240);

C2:=LLV(AA,240);

C3:=C1-C2;

C4:=EMA((AA-C2)/C3,2)*100;

长期:C4,COLORRED,LINETHICK1,DOTLINE ;}

STICKLINE(K1>=REF(K1,1) AND K1>=50,105,101,2,0) ,COLORFF00FF,LINETHICK5;

STICKLINE(K1<REF(K1,1) AND K1>=50,105,101,2,0) ,COLORGREEN,LINETHICK5;

STICKLINE(K1>REF(K1,1) AND K1>80,105,101,2,0) ,COLORRED,LINETHICK5;

STICKLINE(K1<REF(K1,1) AND K1>80,105,101,2,0) ,COLORCYAN,LINETHICK5;

今▼日▼跌停价:REF(C,1)*0.9,LINETHICK0,COLORFF00FF;

今▲日▲涨停价:REF(C,1)*1.1,LINETHICK0,COLORFF00FF;

VAK1:=IF(YEAR>=2038 AND MONTH>=1,0,1);

VAK2:=REF(LOW,1)*VAK1;

VAK3:=SMA(ABS(LOW-VAK2),3,1)/SMA(MAX(LOW-VAK2,0),3,1)*100*VAK1;

VAK4:=EMA(IF(CLOSE*1.3,VAK3*10,VAK3/10),3)*VAK1;

VAK5:=LLV(LOW,30)*VAK1;

VAK6:=HHV(VAK4,30)*VAK1;

VAK7:=IF(MA(CLOSE,58),1,0)*VAK1;

VAK8:=EMA(IF(LOW<=VAK5,(VAK4+VAK6*2)/2,0),3)/618*VAK7*VAK1;

吸筹:=IF(VAK8>100,100,VAK8)*VAK1;

跟庄吸:=IF(吸筹<REF(吸筹,1) AND (REF(吸筹,1)>REF(吸筹,2) OR REF(吸筹,1)=100),1,0);

吸筹累计:=SUM(吸筹,60);

庄三吸:=COUNT(跟庄吸,30)=3 AND 跟庄吸=1 AND 吸筹累计>200;

狠吸筹:=REF(吸筹,1)=100 AND 吸筹<REF(吸筹,1) AND 吸筹累计>260;

狠吸筹2:=REF(吸筹,1)>REF(吸筹,2) AND 90<REF(吸筹,1) AND 吸筹<REF(吸筹,1) AND 吸筹累计>260;

跟庄买:STICKLINE(庄三吸=1 OR 狠吸筹=1 OR 狠吸筹2=1,0,20,1,1),COLORFFFFFF;

DRAWTEXT(跟庄买,25.4,'底'),COLORFFFF00;

A77:=((CLOSE - (MA(CLOSE,13))) / (MA(CLOSE,13))) * -100;

A78:=((CLOSE - (LLV(LOW,13))) / ((HHV(HIGH,13)) - (LLV(LOW,13)))) * 100;

A79:=SMA(A78,3,2);

A80:=SMA(A79,3,2);

A81:=SMA(A80,5,1);

牛势股票:(((REF(A77,1)) >= 16) AND (((REF(A77,1)) / A77) >= 1.23)) AND (CROSS(A80,A81)),COLORRED;

STICKLINE((牛势股票 > 0),0.9,89,1,0),COLORRED ;

DRAWTEXT(牛势股票,85,' 妖股'),COLORYELLOW ;

股价趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;

底部警戒: 10,COLORRED,LINETHICK0;

买入警戒:STICKLINE(股价趋势<=10,0,10,3,0),COLORMAGENTA ;

买入信号: STICKLINE(CROSS(股价趋势,底部警戒),0,35,1,1),COLORYELLOW ,LINETHICK2;

DRAWICON(CROSS(股价趋势,底部警戒),40,24);

VAAR1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

VAAR2:=SMA(VAAR1,20,1);

VAAR3:=SMA(VAAR2,15,1);

VAAR4:=(3*VAAR2+2*VAAR3)/4;

VAAR5:= REF(VAAR4,1);

RSA:SMA(MAX(VAAR4-VAAR5,0),2,1)/SMA(ABS(VAAR4-VAAR5),2,1)*100 ,COLORYELLOW ,LINETHICK1 ,NODRAW;

RSB:MA(RSA,10),NODRAW;

注意:IF(CROSS(RSA,RSB),2,0),STICK,COLORMAGENTA ;

洛带:IF(CROSS(RSB,90),2,0),STICK,COLORGREEN;

DRAWTEXT(CROSS(RSA,RSB),1,'注意'),COLORRED ;

DRAWTEXT(CROSS(RSB,90),1,'.'),COLORGREEN ;

RSV:=(C-LLV(L,2))/(HHV(H,2)-LLV(L,2))*100;

K:=SMA(RSV,2,1),COLORFFFFFF;

D:=SMA(K,2,1),COLOR00FFFF;

J:3*K-2*D,COLORFF00FF,NODRAW ;

WR:100-100*(HHV(HIGH,2)-CLOSE)/(HHV(HIGH,2)-LLV(LOW,2)),NODRAW ,COLORYELLOW;

IF(WR=100,94,DRAWNULL),CIRCLEDOT,COLOR00FFFF,LINETHICK5;

IF(J>100,96,DRAWNULL),CIRCLEDOT,COLORFF00FF,LINETHICK5;


群贤毕至

访客