×

通达信CCI底背离指标公式

wwwlinqiu wwwlinqiu 发表于2022-02-20 14:02:46 浏览225 评论0

抢沙发发表评论

11.png

N:=14;

TYP:=(HIGH+LOW+CLOSE)/3;

cci:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));

rsi1:=CCI;

AA:=REF(RSI1,N)=HHV(RSI1,2*N+1);

BB:=BacKSET(AA,N+1);

CC:=FILTER(BB,N) AND RSI1=HHV(RSI1,N+1);

A1:=BArslAst(REF(CC,1));

顶背离:REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC,;

DRAWICON(顶背离,CCI*0.9,2);

DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORGREEN,LINETHICK1;

AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);

BB2:=BACKSET(AA2,N+1);

CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);

A2:=BARSLAST(REF(CC2,1));

底背离:REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)<RSI1 AND CC2;

DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK1;

DRAWICON(底背离,-130,1);

CCI底背离:=底背离 AND crOSS(CCI,-100);

DRAWICON(CCI底背离,-150,3);

DRAWTEXT(底背离,-130,'上穿-100是才能买入'),COLOR00FF00;

X:=CROSS(CCI,-100);

DRAWICON(X,-100,5);

IF(CCI>=100,CCI,DRAWNULL),COLORGREEN;

IF(CCI<=-100,CCI,DRAWNULL),COLORRED;


群贤毕至

访客